OnViewBegin Method


IExport Context On View Begin Method

This method marks the beginning of a 3D view to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
RenderNodeAction OnViewBegin(
	ViewNode node
)

Parameters

node ViewNode
Geometry node associated with the view.

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip exporting this view, or return RenderNodeAction.Proceed otherwise.
See Also