DockablePaneId Class


Dockable Pane Id Class

Identifier for a pane that participates in the Revit docking window system.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GuidEnum
Autodesk.Revit.UI DockablePaneId

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePaneId : GuidEnum

The DockablePaneId type exposes the following members.

Constructors
Name Description
Public method DockablePaneId Creates a new DockablePaneId instance.
Top
Properties
Name Description
Public property Guid The Guid of GUID-based enum object.
(Inherited from GuidEnum )
Top
Methods
Name Description
Public method Equals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum )
Public method GetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Operators
Name Description
Public operator Static member Equality(DockablePaneId, DockablePaneId) Compares two DockablePaneId instances.
Public operator Static member Inequality(DockablePaneId, DockablePaneId) Compares two DockablePaneId instances.
Top
See Also