Rebar |
Specify a parameter to drive the circumference of the shape.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void AddConstraintCircumference(
ElementId paramId,
RebarShapeArcReferenceType arcRefType
)
Parameters
- paramId ElementId
- Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
- arcRefType RebarShapeArcReferenceType
- Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |