CreateNURBSSurface Method (Int32, Int32, IList(Double), IList(Double), IList(XYZ), Boolean, BoundingBoxUV)


BRep Builder Surface Geometry Create NURBSSurface(Int 32, Int 32, IList Double , IList Double , IList XYZ , Boolean, Bounding Box UV) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static BRepBuilderSurfaceGeometry CreateNURBSSurface(
	int degreeU,
	int degreeV,
	IList<double> knotsU,
	IList<double> knotsV,
	IList<XYZ> controlPoints,
	bool bReverseOrientation,
	BoundingBoxUV surfaceEnvelope
)

Parameters

degreeU Int32
degreeV Int32
knotsU IList Double
knotsV IList Double
controlPoints IList XYZ
bReverseOrientation Boolean
surfaceEnvelope BoundingBoxUV

Return Value

BRepBuilderSurfaceGeometry
See Also