Spherical |
This class encapsulates a spherical light distribution.

System Object
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting SphericalLightDistribution
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting SphericalLightDistribution
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SphericalLightDistribution type exposes the following members.

Name | Description | |
---|---|---|
![]() | SphericalLightDistribution | Creates a spherical light distribution object. |
![]() | SphericalLightDistribution(SphericalLightDistribution) | Creates a copy of the given spherical light distribution |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LightDistribution ) |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution ) |
![]() | Dispose | (Inherited from LightDistribution ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |