Schedule |
The type of data displayed in a schedule field.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
Analytical | 17 | A parameter of the analytical element of a scheduled physical element. |
CombinedParameter | 20 | Combine parameters of the types that display in a specific part of a schedule. The values for the combined parameters will display in the same cell separated by a slash or other separator. You can add a prefix, suffix or sample value to the parameter. |
Count | 2 | The number of elements appearing on the schedule row. |
CustomField | 24 | For this field type the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet. |
ElementType | 1 | A type parameter of the scheduled elements. |
Formula | 5 | A formula calculated from the values of other fields in the schedule. |
FromRoom | 8 | A parameter of the room on the "from" side of a door or window. |
HostCount | 23 | Counts the number of hosts with different mark. |
Instance | 0 | An instance parameter of the scheduled elements. All shared parameters also use this type, regardless of whether they are instance or type parameters. |
Material | 11 | In a material takeoff, a parameter of one of the materials of a scheduled element. |
MaterialQuantity | 12 | In a material takeoff, a value representing how a particular material is used within a scheduled element. The parameter ID can be MATERIAL_AREA, MATERIAL_VOLUME, or MATERIAL_ASPAINT. |
Percentage | 6 | A value indicating what percent of the total of another field each element represents. |
PhysicalInstance | 19 | An instance parameter of the physical element of a scheduled analytical element. |
PhysicalType | 18 | A type parameter of the physical element of a scheduled analytical element. |
ProjectInfo | 10 | A parameter of the Project Info element in the project that the scheduled element belongs to, which may be a linked file. Only allowed in schedules that include elements from linked files. |
Revision | 25 | A parameter of the revision element that the scheduled revision cloud element belongs to. |
RevitLinkInstance | 13 | A parameter of the RevitLinkInstance that an element in a linked file belongs to. Currently RVT_LINK_INSTANCE_NAME is the only supported parameter. Only allowed in schedules that include elements from linked files. |
RevitLinkType | 14 | A parameter of the RevitLinkType that an element in a linked file belongs to. Currently RVT_LINK_FILE_NAME_WITHOUT_EXT is the only supported parameter. Only allowed in schedules that include elements from linked files. |
Room | 7 | A parameter of the room that a scheduled element belongs to. |
Sheets | 27 | A parameter of the sheet view owning an annotation element (e.g. Revision Cloud) |
Space | 16 | A parameter of the space that a scheduled element belongs to. |
StructuralMaterial | 15 | A parameter of the structural material of a scheduled element. |
ToRoom | 9 | A parameter of the room on the "to" side of a door or window. |
ViewBased | 4 | A specialized type of field used for a few parameters whose displayed values can change based on the settings of the view:
|
Views | 26 | A parameter of the primary view owning an annotation element (e.g. Revision Cloud) |