OptionalFunctionalityUtils Class


Optional Functionality Utils Class

A collection of utilities that can be used to determine if a particular set of functionality is installed and available.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB OptionalFunctionalityUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class OptionalFunctionalityUtils

The OptionalFunctionalityUtils type exposes the following members.

Methods
Name Description
Public method Static member Is3DMImportLinkAvailable Checks whether the 3DM Import/Link functionality is available in the installed Revit.
Public method Static member IsAXMImportLinkAvailable Checks whether the AXM Import/Link functionality is available in the installed Revit.
Public method Static member IsDGNExportAvailable Checks whether the DGN Export functionality is available in the installed Revit.
Public method Static member IsDGNImportLinkAvailable Checks whether the DGN Import/Link functionality is available in the installed Revit.
Public method Static member IsDWFExportAvailable Checks whether the DWF/DWFx Export functionality is available in the installed Revit.
Public method Static member IsDWGExportAvailable Checks whether the DWG Export functionality is available in the installed Revit.
Public method Static member IsDWGImportLinkAvailable Checks whether the DWG Import/Link functionality is available in the installed Revit.
Public method Static member IsDXFExportAvailable Checks whether the DXF Export functionality is available in the installed Revit.
Public method Static member IsFBXExportAvailable Checks whether the FBX Export functionality is available in the installed Revit.
Public method Static member IsGraphicsAvailable Checks whether the graphics functionality is available to support display, print, and export functionality.
Public method Static member IsIFCAvailable Checks whether IFC functionality is available in the installed Revit.
Public method Static member IsNavisworksExporterAvailable Checks whether a Navisworks Exporter is available in the installed Revit.
Public method Static member IsOBJImportLinkAvailable Checks whether the OBJ Import/Link functionality is available in the installed Revit.
Public method Static member IsPDFImportAvailable Obsolete.
Checks whether PDF import is available in the installed Revit.
Public method Static member IsSATImportLinkAvailable Checks whether the SAT Import/Link functionality is available in the installed Revit.
Public method Static member IsShapeImporterAvailable Checks whether the ShapeImporter functionality is available in the installed Revit.
Public method Static member IsSKPImportLinkAvailable Checks whether the SKP Import/Link functionality is available in the installed Revit.
Public method Static member IsSTEPImportLinkAvailable Checks whether the STEP Import/Link functionality is available in the installed Revit.
Public method Static member IsSTLImportLinkAvailable Checks whether the STL Import/Link functionality is available in the installed Revit.
Top
See Also