AssetPropertyDistance Class


Asset Property Distance Class

Represents a property of material.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AssetProperty
Autodesk.Revit.DB.Visual AssetPropertyDistance

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetPropertyDistance : AssetProperty

The AssetPropertyDistance type exposes the following members.

Properties
Name Description
Public property IsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
(Inherited from AssetProperty )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssetProperty )
Public property Name Get the name of the AssetProperty
(Inherited from AssetProperty )
Public property NumberOfConnectedProperties The number of currently connected properties.
(Inherited from AssetProperty )
Public property Type Returns the type of the AssetProperty
(Inherited from AssetProperty )
Public property Value Value of the property.
Top
Methods
Name Description
Public method AddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
(Inherited from AssetProperty )
Public method Code example AddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
(Inherited from AssetProperty )
Public method Dispose
(Inherited from AssetProperty )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
(Inherited from AssetProperty )
Public method GetConnectedProperty Gets one connected property with specified index.
(Inherited from AssetProperty )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Code example GetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
(Inherited from AssetProperty )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetUnitTypeId Gets the identifier of the unit quantifying the distance property.
Public method IsEditable Check if property can be edited.
(Inherited from AssetProperty )
Public method IsValidSchemaIdentifier Check that schema name is valid
(Inherited from AssetProperty )
Public method IsValidValue Checks that the value is a valid value for this property.
Public method RemoveConnectedAsset Removes the connected asset attached to this asset property if any.
(Inherited from AssetProperty )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also