Point |
Indicates if the point is inside panel's boundaries or if the point is on the member's curve..
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsPointInsideHostBoundaries(
Document pDoc,
ElementId hostId,
XYZ point
)
Parameters
- pDoc Document
- The document containing both the host and the load.
- hostId ElementId
- The id of the analytical element that is about to host a point load.
- point XYZ
- The position of point load, measured in decimal feet.
Return Value
BooleanTrue if a point load can be placed on the input host id

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |