BuiltInFailures.DimensionFailures Class


Built In Failures Dimension Failures Class

Failures about DimensionFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures DimensionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DimensionFailures

The BuiltInFailures DimensionFailures type exposes the following members.

Properties
Name Description
Public property Static member AngularDimensionRegenFailed Can't form Angular Dimension.
Public property Static member ArcAlignmentRegenFailed Can't form arc alignment.
Public property Static member ArcLengthDimensionNoReferencesOnArc None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
Public property Static member ArcLengthDimensionReferencesNotIntersect One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
Public property Static member AssocpropNeedJog Need to add jog in order to satisfy constraints
Public property Static member CannotConstrainBasePointAlignments Alignments to base points cannot be constrained.
Public property Static member CannotConstrainBasePointDimensions Dimensions to base points cannot be constrained.
Public property Static member CannotCreateDimensionNotParallel Can't create dimension. Highlighted references are not parallel to first selection.
Public property Static member CannotDragWitnessLine Moving the Witness Line conflicts with other Constraints in the Sketch.
Public property Static member CannotLockThisDimension Can't lock this Dimension because it breaks formulas
Public property Static member CannotToggleDimensionEquality Toggling the dimension's equality constraint would overconstrain the sketch.
Public property Static member ChangeDimensionSegmentFailed Can't change dimension segment to this value.
Public property Static member ChangeSpotElevationFailed Can't change Spot Elevation to the desired value.
Public property Static member DifferentLabelsInMultiSegmentDim All segments of a multi-segment dimension must be labeled the same.
Public property Static member DimensionOverconstrained The Dimension would overconstrain the Sketch.
Public property Static member DimensionOverconstrainedError The Dimension would overconstrain the Sketch.
Public property Static member DimensionOverrideNearByIsLost The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
Public property Static member DimensionPerpendicularToView The Dimension is perpendicular to the current view, and no longer valid.
Public property Static member DimensionReferencesInvalid One or more dimension references are or have become invalid.
Public property Static member DimensionUnequaled Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
Public property Static member DimensionUnlocked Dimension had to be un-EQed in order to remove sketch over-constraining.
Public property Static member DimensionUnlockedAndUnequaled Dimension had to be unlocked in order to remove sketch over-constraining.
Public property Static member EqualityConstraintsUnsatisfied Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
Public property Static member EqualityConstraintsUnsatisfiedWarn Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
Public property Static member ForbiddenGroupConstraint You may not create sketch or family constraints between group members and elements which are not members of the same group.
Public property Static member LabelingDimWithGroupReferences Labeled constraints cannot participate in groups.
Public property Static member LabelingMultiSegmentWithReporting Cannot label multi-segment dimensions with reporting parameters.
Public property Static member LabelOverconstrained Labeling this dimension would overconstrain the sketch.
Public property Static member LinearConstraintBadDirection Bad direction vector in dimension element.
Public property Static member LinearConstraintNotParallel The References of the highlighted Dimension are no longer parallel.
Public property Static member LinearDimensionReferenceNotOrthogonalToView The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
Public property Static member LockOverconstrained Locking this dimension would overconstrain the sketch.
Public property Static member LockOverconstrainedAlignment Locking this alignment would overconstrain the sketch.
Public property Static member LooseLabeledDimensionRegenFailure Failed to Regenerate Family
Public property Static member MoreThanOneDimsLabelToOneReportingParameter Reporting parameters can only exist on a single dimension/constraint.
Public property Static member NoConstraintsInProperSketch You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
Public property Static member NoConstraintsToLinks Constraints may not be created to linked instances using Shared Locations.
Public property Static member RadialDimensionCannotProjectToArc Cannot form radial dimension.
Public property Static member RadialDimensionChangeRadiusFailed Can't change radius.
Public property Static member RegenConstraintUnsatisfied Constraints are not satisfied
Public property Static member RegenConstraintUnsatisfiedWarn Constraints are not satisfied
Public property Static member ReportingParamAlreadyLabelsToAnotherDim Cannot label multi-dimensions to one reporting parameter.
Public property Static member SomeDimensionsLostOnPaste Some Dimensions were not copied because some References were lost.
Public property Static member SomeDimensionsLostWitnessLines Some Dimensions lost some of their References on paste.
Public property Static member SomeSpotDimensionsLostOnPaste Some Spot Dimensions were not copied because some References were lost.
Public property Static member SpotDimensionFloatingPointError Some spot dimensions contain invalid floating-point values.
Public property Static member SpotDimensionFormerSetMoribundCall One or more Spot Dimension references are no longer valid.
Public property Static member SpotDimensionReferencesNoLongerHorizontal One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
Public property Static member SpotElevationLostEdgeReferences Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
Public property Static member SpotElevationMissesReference Spot Dimension does not lie on its reference.
Public property Static member SpotSlopeReferenceIsVertical The highlighted Spot Slope references an element that is vertical.
Public property Static member SpotSlopeReferencePointIsSingular The highlighted Spot Slope references an element point that is singular.
Public property Static member UnavailableDimensionHostReference A dimension reference could not be resolved on the host element.
Public property Static member UnstableConstraintInFamily Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
Public property Static member WrongConstraintInGridChainSketch Curve in a GridChain sketch cannot be constrained to a sub-grid
Public property Static member WrongConstraintInJoistSystemSketch Structural Beam System sketch can't be constrained to its beam.
Public property Static member WrongConstraintInSkeletonSketch Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
Public property Static member WrongConstraintInTrussSketch Structural Truss sketch can't be constrained to its members.
Top
See Also