Boundary |
An object that represents a segment of an area boundary.

System Object
Autodesk.Revit.DB BoundarySegment
Autodesk.Revit.DB BoundarySegment
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The BoundarySegment type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BoundarySegment |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCurve | Get a copy of the curve that is formed along this boundary. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the id of the element that is responsible for producing that boundary.