OnFaceBegin Method


IExport Context On Face Begin Method

This method marks the beginning of a Face to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
RenderNodeAction OnFaceBegin(
	FaceNode node
)

Parameters

node FaceNode
An output node that represents a Face.

Return Value

RenderNodeAction
Return RenderNodeAction. Proceed if you wish to receive geometry (polymesh) for this face, or return RenderNodeAction.Skip otherwise.
Remarks
Note that this method (as well as OnFaceEnd) is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
See Also