AdaptivePointConstraintType Enumeration


Adaptive Point Constraint Type Enumeration

An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum AdaptivePointConstraintType
Members
Member name Value Description
Axis_X 4 Constrained to the X Axis (y=0, z=0).
Axis_Y 5 Constrained to the Y Axis (x=0, z=0).
Axis_Z 6 Constrained to the Z Axis (x=0, y=0).
None 0 Not constrained.
Plane_XY 3 Constrained to the XY Plane (z=0).
Plane_YZ 1 Constrained to the YZ Plane (x=0).
Plane_ZX 2 Constrained to the ZX Plane (y=0).
See Also