RemoveReferenceObject Method (String)


Direct Shape Type Remove Reference Object(String) Method

Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveReferenceObject(
	string refName
)

Parameters

refName String
The name of the reference object(s) to be removed.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also