BuiltInFailures.MEPCalculationFailures Class


Built In Failures MEPCalculation Failures Class

Failures about Fluid.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures MEPCalculationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MEPCalculationFailures

The BuiltInFailures MEPCalculationFailures type exposes the following members.

Properties
Name Description
Public property Static member AtLeastOneEquipmentOnDuty There should be at least one equipment on duty.
Public property Static member ClassificationNotSetInFamily A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
Public property Static member DemandFlowNotSetInLossFamily A calculation did not complete because the Demand Flow for the element is not set.
Public property Static member DuctFittingAndAccessoryPressureDropCalculatorNotAvailable Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
Public property Static member DuctPressureDropCalculatorNotAvailable Duct Pressure Drop Calculator Not Available: [Calculator Name]
Public property Static member ExtraPumpSet More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
Public property Static member FlowAndPressureCalculationMethodHasBeenImproved During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
Public property Static member HydraulicSeparationAmbiguity Unable to hydraulically separate until the system has flow.
Public property Static member HydraulicSeparationOfOneSystem Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
Public property Static member InvalidFluidProperty Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
Public property Static member InvalidNumberOfMechanicalEquipmentOnDuty The number of on duty equipment must be less than or equal to the number of available equipments.
Public property Static member LoopSeparationNotCompleted The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
Public property Static member MechanicalEquipmentSetBeingDeleted The mechanical equipment set was deleted because it no longer contained any members.
Public property Static member Network_ElementNodeIsNotPartOfNetwork The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Public property Static member Network_NodePropertyNotSet The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Public property Static member Network_NoInputNode The calculation could not be executed as configured. Select an input node before analyzing this network.
Public property Static member Network_NoOutputNode The calculation could not be executed as configured. Select an output node before analyzing this network.
Public property Static member Network_NoPressureConstraint The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Public property Static member Network_NotEnoughElements The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Public property Static member Network_NotEnoughNodes The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Public property Static member Network_NotFullyConnected The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Public property Static member Network_OverConstrained The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
Public property Static member NetworkCanNotDeterminCriticalPath The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
Public property Static member NetworkDefaultToPressure The network uses the default pressure.
Public property Static member NetworkDefaultToReynolds The network uses the default Reynolds number.
Public property Static member NetworkEnergyEquationNotConverge The energy calculation could not be performed.
Public property Static member NetworkErrorCalculatingPressure The pressure calculation could not be performed.
Public property Static member NetworkErrorElementWithDownUpStreamNode The network needs an input or output element to perform the calculation.
Public property Static member NetworkErrorExtractCurveData The calculation could not be performed. Verify the pump curve data.
Public property Static member NetworkErrorModelTooBig The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
Public property Static member NetworkErrorOverConstrained The calculation could not be performed due to overconstrained flow condition in the network.
Public property Static member NetworkExtraPumpOutsideSet Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
Public property Static member NetworkInconsistentDemandFlow The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
Public property Static member NetworkMinorLossNotConverge The minor loss calculation could not be performed.
Public property Static member NetworkPressureNotConverge The calculation could not be performed. Verify the pressure on the input element.
Public property Static member NetworkUnderConstrained The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
Public property Static member PipeConnectorsAreNotLined A calculation did not complete because the connectors used by this family to connect to the network are not linked.
Public property Static member PipeFittingAndAccessoryPressureDropCalculatorNotAvailable Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
Public property Static member PipePressureDropCalculatorNotAvailable Pipe Pressure Drop Calculator Not Available: [Calculator Name]
Public property Static member PlumbingFlowCalculatorNotAvailable Plumbing Flow Calculator Not Available: [Calculator Name]
Public property Static member PumpPressureNotComputed The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
Public property Static member SeparationNotAtJunction This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
Public property Static member SeparationWithOddJunction Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.
Top
See Also