GetLayerNameForPresentationLayer Method


Exporter IFC Get Layer Name For Presentation Layer Method

Get the layer name associated with an element from the default layer mapping table.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetLayerNameForPresentationLayer(
	Element pElement,
	ElementId categoryId
)

Parameters

pElement Element
The element.
categoryId ElementId
The category id of the element.

Return Value

String
The layer name.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also