MEPAnalyticalModelData Class


MEPAnalytical Model Data Class

Represents the MEP analytical model data attached to individual element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis MEPAnalyticalModelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPAnalyticalModelData : IDisposable

The MEPAnalyticalModelData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPAnalyticalModelData
Public method Static member GetMEPAnalyticalModelData Gets the MEP analytical model data of the specified element.
Public method GetNodeById Gets the analytical node with the specified id.
Public method GetNodeByIndex Gets the specified analytical node.
Public method GetNumberOfNodes Returns the number of analytical nodes.
Public method GetNumberOfSegments Returns the number of analytical segments.
Public method GetSegmentById Gets the analytical segment with the specified id.
Public method GetSegmentByIndex Gets the analytical segment at the specified position.
Public method GetSegmentData Gets the analysis data on the specified segment.
Public method IsValidNodeId Verifies if a valid analytical node id.
Public method IsValidSegmentId Verifies if a valid segment id.
Top
Remarks
The MEP analytical model is composed of generic analytical segments and nodes. Each Revit element may have one or more analytical segments. Connected together, these data form a network that is used in the flow and pressure drop calculation.
See Also