Rebar |
Verifies if the rebar can be spliced with the provided line.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RebarSpliceError CanRebarBeSpliced(
Rebar rebar,
RebarSpliceOptions spliceOptions,
Line line,
XYZ linePlaneNormal
)
Parameters
- rebar Rebar
- The rebar to be spliced.
- spliceOptions RebarSpliceOptions
- The RebarSpliceOptions.
- line Line
- The line to splice the rebar with.
- linePlaneNormal XYZ
- The normal that determines the plane of the line.
Return Value
RebarSpliceErrorWill return RebarSpliceError.Success if it's possible to splice with line or other enum value corresponding to the error that occurred.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If the provided linePlaneNormal is parallel with the bar plane normal the bounded line will be used to calculate the splice geometries where the bar will be split.
Otherwise, the line will be extended to exceed the bounding box of the bar.