GetDefaultNameForMaterialTakeoff Method


View Schedule Get Default Name For Material Takeoff Method

Gets the default view name that will be used when creating a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetDefaultNameForMaterialTakeoff(
	Document document,
	ElementId categoryId
)

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

String
The default view name.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- categoryId is not a valid category for a material takeoff.
ArgumentNullException A non-optional argument was null
See Also