IFCFileModelOptions Class


IFCFile Model Options Class

This class contains options to create an IFC file model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCFileModelOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCFileModelOptions : IDisposable

The IFCFileModelOptions type exposes the following members.

Constructors
Name Description
Public method IFCFileModelOptions Creates a default IFCFileModelOptions. The default schema file is empty and cache size is 8192.
Top
Properties
Name Description
Public property CacheSize The cache size of the file.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SchemaFile The full name of an IFC schema file.
Public property SchemaName The name of the schema.
Public property UserControlledInverses Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCFileModelOptions
Top
See Also