NewRoom Method (Room, PlanCircuit)


Document New Room(Room, Plan Circuit) Method

Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Room NewRoom(
	Room room,
	PlanCircuit circuit
)

Parameters

room Room
The room which you want to locate in the circuit. Pass to create a new room.
circuit PlanCircuit
The circuit in which you want to locate a room.

Return Value

Room
If successful the room is returned, otherwise .
Exceptions
Exception Condition
InvalidOperationException If the existing room is already placed.
ArgumentException Thrown if the room does not exist in the given document.
ArgumentException Thrown if the circuit does not exist in the given document.
InvalidOperationException Thrown if the level obtained from the circuit has no associated view .
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also