Filter |
Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The FilterDialog type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterDialog(Document, ElementId) | Constructs a new instance of the FilterDialog class, while setting the id of the FilterElement to be selected when the dialog is shown. |
![]() | FilterDialog(Document, String) | Constructs a new instance of the FilterDialog class, while setting the name of the new ParameterFilterElement to be created and selected for editing. |

Name | Description | |
---|---|---|
![]() | FilterToSelect | The filter element to be selected once Show is invoked. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | NewFilterId | The ElementId of the new filter created. The value is populated after Show method is executed. |
![]() | NewFilterName | The name of the new ParameterFilterElement to be created and selected once Show is invoked. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FilterDialog |
![]() | Show | Shows the FilterDialog editing dialog to the user. |

The class provides the option to launch the dialog by selecting an existing FilterElement, or automatically creating a new ParameterFilterElement. In both cases the affected element will be selected for editing. Note that the user may opt to add, delete or edit any of the available filter elements (or make no changes at all).