Create Method


Structural Connection Type Create Method

Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static StructuralConnectionType Create(
	Document doc,
	StructuralConnectionApplyTo applyTo,
	string name,
	ElementId familySymbolId
)

Parameters

doc Document
applyTo StructuralConnectionApplyTo
Specify which type of member this connection type can be applied to.
name String
A name for the connection type. It must be unique within the document.
familySymbolId ElementId
The id of an annotation FamilySymbol. InvalidElementId is allowed. Otherwise, the FamilySymbol must be in the category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo argument.

Return Value

StructuralConnectionType
Exceptions
Exception Condition
ArgumentException familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to applyTo.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also