Fabrication |
Creates a hanger on the fabrication part.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FabricationPart CreateHanger(
Document document,
FabricationServiceButton button,
ElementId hostId,
Connector hostConnector,
double distance,
bool attachToStructure
)
Parameters
- document Document
- The document.
- button FabricationServiceButton
- The fabrication service button to use. It finds the matching condition automatically if the button has multiple condition.
- hostId ElementId
- The host part id. The host should be one horizontal straight part.
- hostConnector Connector
- The connector of the host.
- distance Double
- The distance from the input connector of the host part. Units are in feet (ft).
- attachToStructure Boolean
- Attach to the nearest structural element. The structural element might be one of Floor/Roof/Stair/Structure Framing.
Return Value
FabricationPartThe newly-created fabrication hanger.

Exception | Condition |
---|---|
ArgumentException | Hangers may only be placed on straight horizontal fabrication segments and some kind of fittings. -or- Invalid fabrication service button. -or- The distance is out of range. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | cannot place hanger on the host. |