RPCNode Class


RPCNode Class

This class represents an RPC content in a model-exporting process.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RPCNode : ContentNode

The RPCNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAsset Returns an an instance of an Asset object, which contains definitions of the content node.
(Inherited from ContentNode )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetTransform A transformation matrix associated with the node.
(Inherited from ContentNode )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnRPC] .
See Also