Compound |
Gets the orientation of a segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- segmentId Int32
- The id of a segment in this CompoundStructure.
Return Value
RectangularGridSegmentOrientationThe orientation of the specified segment.

Exception | Condition |
---|---|
ArgumentException | The segment id is invalid. |
InvalidOperationException | This operation is valid only for vertically compound structures. |

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.