Span |
Places a new instance of the Span Direction Symbol into the project relative to a particular host element and view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static SpanDirectionSymbol Create(
Document document,
ElementId viewId,
LinkElementId elemIdToTag,
XYZ headPosistion,
ElementId symbolId
)
Parameters
- document Document
- The document.
- viewId ElementId
- The id of the view in which the symbol should appear.
- elemIdToTag LinkElementId
- The ElementId of a Floor (either in the document or linked from another document).
- headPosistion XYZ
- The span symbol's head position.
- symbolId ElementId
- The id of the family symbol of this span symbol.
Return Value
SpanDirectionSymbolReturns the newly created symbol.

Exception | Condition |
---|---|
ArgumentException | The specified viewId should represent a Plan View. -or- The specified elemIdToTag should represent a Floor element. -or- The specified symbolId isn't valid. It should be a FamilySymbol of OST_SpanDirectionSymbol category. |
ArgumentNullException | A non-optional argument was null |