IIFCImporterServer Interface


IIFCImporter Server Interface

Interface for external servers implementing IFC import.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IIFCImporterServer : IExternalServer

The IIFCImporterServer type exposes the following members.

Methods
Name Description
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method ImportIFC The method that Revit will invoke to perform an import from IFC.
Top
See Also