ConnectTo Method


Wire Connect To Method

Connects the wire to other elements.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConnectTo(
	Connector startConnectorTo,
	Connector endConnectorTo
)

Parameters

startConnectorTo Connector
The connector that the start connector of the wire connects to.
endConnectorTo Connector
The connector that the end connector of the wire connects to.
Exceptions
Exception Condition
ArgumentException startConnectorTo cannot be connected to a wire, as it is not an electrical connector. -or- endConnectorTo cannot be connected to a wire, as it is not an electrical connector. -or- startConnectorTo or/and endConnectorTo cannot be connected to a wire, as wire can't connect both connectors to same wire or same connector.
InvalidOperationException Cannot connect the wire to the start connector or the end connector.
See Also