Curve Get |
Returns the 3D point at the start or end of this curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- index Int32
- 0 for the start or 1 for end of the curve.
Return Value
XYZThe curve endpoint.

Exception | Condition |
---|---|
ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end. |
ArgumentNullException | A non-optional argument was NULL |