SetLightShapeStyle Method


Light Family Set Light Shape Style Method

Set the light shape style to the given shape style

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetLightShapeStyle(
	LightShapeStyle lightShapeStyle
)

Parameters

lightShapeStyle LightShapeStyle
The light shape style value to set the light shape style to
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also