Delete Method (ElementId)


Document Delete(Element Id) Method

Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ICollection<ElementId> Delete(
	ElementId elementId
)

Parameters

elementId ElementId
Id of the element to delete.

Return Value

ICollection ElementId
The deleted element id set.
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document -or- ElementId cannot be deleted.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed. The elements will be deleted with no prompts for user confirmation. Pinned elements will be deleted with no warnings.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

See Also