GetAddedElementIds Method (ElementFilter)


Document Changed Event Args Get Added Element Ids(Element Filter) Method

Returns set of newly added elements that pass the filter.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetAddedElementIds(
	ElementFilter filter
)

Parameters

filter ElementFilter
The element filter to be applied.

Return Value

ICollection ElementId
The set of ElementId for newly added elements that pass the filter. Returns empty set if no elements are found which pass the filter.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also