GetLegacyStairOrRampComponents Method


Exporter IFCUtils Get Legacy Stair Or Ramp Components Method

Gets the components of a stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCLegacyStairOrRamp GetLegacyStairOrRampComponents(
	ExporterIFC exporterIFC,
	Element element
)

Parameters

exporterIFC ExporterIFC
The exporter.
element Element
The legacy stair or ramp element.

Return Value

IFCLegacyStairOrRamp
The LegacyStairOrRamp that contains the components. NULL means the components can't be determined.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also