AddCoping Method


Family Instance Add Coping Method

Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AddCoping(
	FamilyInstance cutter
)

Parameters

cutter FamilyInstance
A steel beam or column. May not be or itself.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException Thrown when 'cutter' is .
ArgumentException Thrown when 'cutter' refers to this instance.
InvalidOperationException Thrown when regeneration fails.
Remarks
This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.
See Also