IDuctPressureDropServer Interface


IDuct Pressure Drop Server Interface

Interface for external servers implementing duct pressure drop calculation.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IDuctPressureDropServer : IExternalServer

The IDuctPressureDropServer type exposes the following members.

Methods
Name Description
Public method Calculate Calculate the duct pressure drop.
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetHtmlDescription The method that Revit will invoke to get an HTML formatted description of the server.
Public method GetInformationLink The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Top
Remarks
A typical way to use the external server can be:
  • Implement a server class that derives from this interface
  • Create a new server object and register it with the service, see ExternalServiceRegistry .
  • Assign server for the duct pressure drop calculation in DuctSettings .
See Also