CriticalPathCollector Class


Critical Path Collector Class

This class is used to search and traverse the network analytical segments on the critical path.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis CriticalPathCollector

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CriticalPathCollector : IEnumerable<MEPNetworkSegmentId>, 
	IDisposable

The CriticalPathCollector type exposes the following members.

Constructors
Name Description
Public method CriticalPathCollector Creates a new CriticalPathCollector that visits the analytical segments on the network critical path.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CriticalPathCollector
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetCalculatedFlow Gets the calculated flow of the network.
Public method GetCalculatedPressureDrop Gets the calculated pressure drop of the network.
Public method GetCriticalPathCollectorIterator Gets the critical path iterator to traverse individual segment.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method ToNetworkSegmentIds Returns the list of analytical segment ids on the network critical path.
Top
Remarks
The critcal path is a connected flow path that has the maximum pressure loss value on the network. The associated flow and pressure loss values are often used to select the equipment size. When this collector is constructed, the network is identified by one analytical segment seed. User may get the CriticalPathIterator from the collector to traverse the analytical segment on the critical path, in the sequence of their flow direction. Note that If the network contains multiple hydraulically separated levels, the critical path traversal is focused on the same hydraulic separation level as the seed segment.
See Also