Rehost Method (Reference, XYZ)


Form Rehost(Reference, XYZ) Method

Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Rehost(
	Reference hostRef,
	XYZ location
)

Parameters

hostRef Reference
The geometry reference on which to rehost the form.
location XYZ
The location to which to Rehost the form.
Exceptions
Exception Condition
ArgumentNullException Thrown when the hostRef or location is .
InvalidOperationException Thrown when rehosting Form failed.
See Also