RectangleLightShape Constructor (Double, Double)


Rectangle Light Shape(Double, Double) Constructor

Creates a rectangle light shape object with the given emit length and width.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RectangleLightShape(
	double emitLength,
	double emitWidth
)

Parameters

emitLength Double
The emit length as a numerical value in feet between 1.0e-9 and 30000.0
emitWidth Double
The emit width as a numerical value in feet between 1.0e-9 and 30000.0
Exceptions
Exception Condition
ArgumentOutOfRangeException The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.
See Also