IsByComponent Method


Stairs Is By Component Method

Indicates if the stairs is created by stairs components(runs, landings and supports).

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsByComponent(
	Document document,
	ElementId stairsId
)

Parameters

document Document
The document.
stairsId ElementId
The stairs element to check.

Return Value

Boolean
True if the stairs is created by components, False otherwise.
Exceptions
Exception Condition
ArgumentException The element stairsId does not exist in the document
ArgumentNullException A non-optional argument was null
See Also