NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)


Family Item Factory New Swept Blend(Boolean, Curve, Sketch Plane, Sweep Profile, Sweep Profile) Method

Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public SweptBlend NewSweptBlend(
	bool isSolid,
	Curve path,
	SketchPlane pathPlane,
	SweepProfile bottomProfile,
	SweepProfile topProfile
)

Parameters

isSolid Boolean
Indicates if the swept blend is Solid or Void.
path Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.
topProfile SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.

Return Value

SweptBlend
If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input arguments-path/bottomProfile/topProfile-are .
ArgumentException Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is .
ArgumentException Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains or more than one curve loops.
ArgumentException Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is .
InvalidOperationException Thrown when creation is attempted in Conceptual Mass, 2D, or other family where swept blends cannot be created.
InvalidOperationException Thrown when the creation failed.
Remarks
This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.
See Also