LinePattern Class


Line Pattern Class

Represents a line pattern definition.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinePattern : IDisposable

The LinePattern type exposes the following members.

Constructors
Name Description
Public method LinePattern Creates a simple line pattern.
Public method LinePattern(String) Creates a line pattern with given name.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name Line pattern name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LinePattern
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetSegments Gets the sequence of segments that defines this line pattern.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetSegments
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit. Line patterns are used in the definition of GraphicsStyle objects. A line pattern is defined by a repeating sequence segments. Each segment is a dash, a dot or a space. A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.
See Also