UIDocument Request |
Requests an asynchronous change of the active view in the currently active document.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentNullException | If the 'view' argument is NULL. |
ArgumentException |
|
InvalidOperationException |
|

This method requests to change the active view by posting a message asynchronously. Unlike setting the ActiveView property, this will not make the change in active view immediately. Instead the request will be posted to occur when control returns to Revit from the API context. This method is permitted to change the active view from the Idling event or an ExternalEvent callback.
The active view cannot be changed when:
- There is an open transaction in the currently active document.
- IsModifiable is true.
- IsReadOnly is true.
- ViewActivating, ViewActivated, or any pre-event (such as DocumentSaving) is being handled.