ExternalResourceServerUtils Class


External Resource Server Utils Class

Contains utilities related to external resource server.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceServerUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternalResourceServerUtils

The ExternalResourceServerUtils type exposes the following members.

Methods
Name Description
Public method Static member IsValidShortName Checks whether the name is a valid short name for the external resource server.
Public method Static member ServerSupportsAssemblyCodeData Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.
Public method Static member ServerSupportsCADLinks Checks that the server referenced by the given ExternalResourceReference supports CAD links.
Public method Static member ServerSupportsIFCLinks Checks that the server referenced by the given ExternalResourceReference supports IFC links.
Public method Static member ServerSupportsKeynotes Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.
Public method Static member ServerSupportsRevitLinks Checks that the server referenced by the given ExternalResourceReference supports Revit links.
Top
See Also