NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)


Family Item Factory New Arc Length Dimension(View, Arc, Reference, Reference, Reference) Method

Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Dimension NewArcLengthDimension(
	View view,
	Arc arc,
	Reference arcRef,
	Reference firstRef,
	Reference secondRef
)

Parameters

view View
The view in which the dimension is to be visible.
arc Arc
The extension arc of the dimension.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when any input argument is .
ArgumentException Thrown when the argument arcRef/ref1/ref2 is invalid.
InvalidOperationException Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also