Document |
The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DocumentSaveToLocalProgressChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DocumentSaveToLocalProgressChangedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentSaveToLocalProgressChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | BeforeSaveToCentral | True if the "save to local" operation is occurring before "save to central"; false if after. |
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs ) |
![]() | FinishedStreams | The number of streams finished since the last time this event was raised. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RevitAPIEventArgs ) |
![]() | Location | Full path of the central model which is to be operated. (Inherited from WorksharedOperationProgressChangedEventArgs ) |
![]() | SaveToLocalFinished | Indicates if the current "save to local" operation has finished. |
![]() | Status | Gets API event status, reflect current operation execution status. (Inherited from WorksharedOperationProgressChangedEventArgs ) |
![]() | TotalStreams | The total expected number of streams to save to local. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RevitAPIEventArgs ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToLocalProgessChangedEventArgs' released since 2017 Subscription Update.