Document |
The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DocumentSaveToLocalProgressChangedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPISingleEventArgs
Autodesk.Revit.DB.Events WorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.Events DocumentSaveToLocalProgressChangedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentSaveToLocalProgressChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | BeforeSaveToCentral | True if the "save to local" operation is occurring before "save to central"; false if after. |
![]() | FinishedStreams | The number of streams finished since the last time this event was raised. |
![]() | SaveToLocalFinished | Indicates if the current "save to local" operation has finished. |
![]() | TotalStreams | The total expected number of streams to save to local. |

Name | Description | |
---|---|---|

It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToLocalProgessChangedEventArgs' released since 2017 Subscription Update.