RebarShapeConstraintProjectedSegmentLength Class


Rebar Shape Constraint Projected Segment Length Class

A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintProjectedSegmentLength

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintProjectedSegmentLength : RebarShapeConstraint

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintProjectedSegmentLength Constructs a new instance of a RebarConstraintProjectEdgedLength object using a shape parameter, direction, and reference types.
Top
Properties
Name Description
Public property Direction A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint )
Public property TripleProductSign Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.
Top
Methods
Name Description
Public method Dispose
(Inherited from RebarShapeConstraint )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint )
Public method GetSegmentEndReferenceType Choice of two possibilities for the start and end references of the length constraint.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The constraint has two references, indexed by 0 and 1, that do not have to correspond to the start and end of the segment. The constraint also specifies a direction as a 2D vector, which is not necessarily parallel to the segment, but must point from the segment's start toward its end.
See Also