AnalyticalTransformerData Class


Analytical Transformer Data Class

Represents the data and parameters of analytical transformer node.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalyticalTransformerData : AnalyticalPowerDistributableNodeData

The AnalyticalTransformerData type exposes the following members.

Properties
Name Description
Public property ApparentPowerRating The apparent power rating value of the analytical transformer.
Public property AssignedPhasesNumber The number of electrical phases assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property AssignedVoltage The voltage assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property ConnectedPhases The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property DistributionSystem The distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property NumberOfPhases Obsolete.
The number of electrical phases.
(Inherited from AnalyticalDistributionNodePropertyData )
Public property SecondaryDistributionSystem The secondary distribution system of the analytical transformer.
Top
Methods
Name Description
Public method Dispose
(Inherited from AnalyticalDistributionNodePropertyData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAllAvailableConnectedPhasesOnDownstream Get all the available electrical connected phases that this power distributable node can provide to the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetApparentPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetConnectedPhasesOnDownstream Get the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetDemandPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetConnectedPhasesOnDownstream Set the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also