GetFilters Method


View Get Filters Method

Gets the filters applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetFilters()

Return Value

ICollection ElementId
The ElementIds of the Filters.
Exceptions
Exception Condition
InvalidOperationException The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
Note that this method returns filters in a set sorted according to their ids. To get filters in the order they are applied to the view use GetOrderedFilters .
See Also