CADLink |
This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CADLinkOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object. |
![]() | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload. |
![]() | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the CADLinkOptions |